[PATCH] D101393: [lld-macho][NFC] define more strings in section_names:: and segment_names::

Jez Ng via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Apr 27 13:54:39 PDT 2021


int3 accepted this revision.
int3 added inline comments.
This revision is now accepted and ready to land.


================
Comment at: lld/MachO/MergedOutputSection.cpp:58-60
+    error("Cannot add merge section; inconsistent type: old=" +
+          std::to_string(SECTION_TYPE & flags) +
+          ", new=" + std::to_string(sectionFlag));
----------------
technically a change in an error message is a functional change :)

It seems like we are lacking a test for this; could you add it in this diff?

Also I think the flags would be more readable as hex values (there's `to_hexString()` in ScopedPrinter.h)


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D101393/new/

https://reviews.llvm.org/D101393



More information about the llvm-commits mailing list