[PATCH] D100523: [lld][MachO] Add support for LC_VERSION_MIN_* load commands
Alexander Shaposhnikov via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue Apr 20 21:12:15 PDT 2021
alexshap added inline comments.
================
Comment at: lld/MachO/InputFiles.cpp:118-137
+ } else if (const auto *cmd =
+ findCommand<version_min_command>(hdr, LC_VERSION_MIN_MACOSX)) {
+ platformInfo.target.Platform = PlatformKind::macOS;
+ platformInfo.minimum = decodeVersion(cmd->version);
+ return platformInfo;
+ } else if (const auto *cmd = findCommand<version_min_command>(
+ hdr, LC_VERSION_MIN_IPHONEOS)) {
----------------
int3 wrote:
> this could be simplified if we modified `findCommand` to look for multiple `LC_*` commands at once...
>
> (I can do it in a follow up)
good idea!
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D100523/new/
https://reviews.llvm.org/D100523
More information about the llvm-commits
mailing list