[PATCH] D100119: [mlir] Rename AVX512 dialect to X86Vector

Emilio Cota via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Apr 12 08:53:55 PDT 2021


cota marked an inline comment as done.
cota added a comment.

So far I only have immediate plans of adding avx.rsqrt to the dialect. I'd expect AVX, AVX512 and SSE ops to be added to this dialect in the future.

I think AVX is an OK name although if we end up adding SSE ops then AVX could be confusing.

Furthermore, if we prefix the ops with the dialect's name, which AFAICT seems to be the convention in MLIR, then naming the dialect AVX might be confusing/ugly. For example, we'd have avx.avx.rsqrt and avx.avx512.rsqrt$width; I'd rather have something else in the prefix or just drop the prefix and call those ops avx.rsqrt and avx512.rsqrt.

I don't feel strongly about this, so if you want me to proceed with AVX (I presume by dropping avx as a prefix for all ops) I'll happily do that.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D100119/new/

https://reviews.llvm.org/D100119



More information about the llvm-commits mailing list