[PATCH] D99192: [NFC] Add tests for scalable vectorization of loops with large stride acesses

David Sherwood via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Apr 1 01:11:17 PDT 2021


david-arm added inline comments.


================
Comment at: llvm/test/Transforms/LoopVectorize/AArch64/sve-large-strides.ll:5
+; CHECK-LABEL: @stride7_i32(
+; CHECK:      vector.body
+; CHECK:        %[[VEC_IND:.*]] = phi <vscale x 4 x i64> [ %{{.*}}, %vector.ph ], [ %{{.*}}, %vector.body ]
----------------
CarolineConcatto wrote:
> Why do many spaces between CHECK and the instructions?
I'm just trying to align the starts of all the instructions, i.e. ensure that '%' lines up in the same column. I think it's a bit easier to read this way. This also matches the behaviour of the automated CHECK line writing tool - utils/update_test_checks.py. For example, I used tests like this as a reference:

  test/Transforms/LoopVectorize/X86/invariant-store-vectorization.ll


================
Comment at: llvm/test/Transforms/LoopVectorize/AArch64/sve-large-strides.ll:11
+; CHECK-NEXT:   %[[VALS:.*]] = add nsw <vscale x 4 x i32> %[[GLOAD]],
+; CHECK-NEXT:   call void @llvm.masked.scatter.nxv4i32.nxv4p0i32(<vscale x 4 x i32> %[[VALS]], <vscale x 4 x i32*> %[[PTRS]]
+entry:
----------------
CarolineConcatto wrote:
> Is there any reason to be more than 1 space?
Again, just trying to follow same convention as utils/update_test_checks.py that's all.


================
Comment at: llvm/test/Transforms/LoopVectorize/AArch64/sve-large-strides.ll:32
+; CHECK-LABEL: @stride7_f64(
+; CHECK:      vector.body
+; CHECK:        %[[VEC_IND:.*]] = phi <vscale x 2 x i64> [ %{{.*}}, %vector.ph ], [ %{{.*}}, %vector.body ]
----------------
CarolineConcatto wrote:
> Could this be label too?
I think in such cases we normally seem to use `CHECK:`, at least for tests generated by utils/update_test_checks.py in llvm/test/Transforms/LoopVectorize/X86/


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D99192/new/

https://reviews.llvm.org/D99192



More information about the llvm-commits mailing list