[PATCH] D99083: [RISCV] Introduce floating point control and state registers
Serge Pavlov via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed Mar 31 23:50:56 PDT 2021
sepavloff added inline comments.
================
Comment at: llvm/lib/Target/RISCV/RISCVInstrInfo.td:1222
+def ReadFRM : ReadSysReg<SysRegFRM, [FRM]>;
+def WriteFRM : WriteSysReg<SysRegFRM, [FRM]>;
----------------
craig.topper wrote:
> Should we use the names of the mnemonics that are defined for these operations? Though I guess there's no name defined for "write" just for swap and read.
Did you mean `frrm` and `fsrm`? Name like `Read*` are more readable. Besides it seems there are no advantages of having codegen pseudos named identically to corresponding instruction aliases. And you are right, `Write*` and `Swap*` correspond to the same mnemonic.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D99083/new/
https://reviews.llvm.org/D99083
More information about the llvm-commits
mailing list