[PATCH] D99692: [globalisel][unittests] Rename setUp() to avoid potential mix up with SetUp() from gtest

Daniel Sanders via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Mar 31 16:36:23 PDT 2021


dsanders created this revision.
dsanders added reviewers: probinson, qcolombet, bogner.
Herald added a subscriber: rovka.
dsanders requested review of this revision.
Herald added a project: LLVM.

Also, make it structurally required so it can't be forgotten and re-introduce
the bug that led to the rotten green tests.


Repository:
  rG LLVM Github Monorepo

https://reviews.llvm.org/D99692

Files:
  llvm/unittests/CodeGen/GlobalISel/CSETest.cpp
  llvm/unittests/CodeGen/GlobalISel/ConstantFoldingTest.cpp
  llvm/unittests/CodeGen/GlobalISel/GISelMITest.h
  llvm/unittests/CodeGen/GlobalISel/KnownBitsTest.cpp
  llvm/unittests/CodeGen/GlobalISel/KnownBitsVectorTest.cpp
  llvm/unittests/CodeGen/GlobalISel/LegalizerHelperTest.cpp
  llvm/unittests/CodeGen/GlobalISel/LegalizerTest.cpp
  llvm/unittests/CodeGen/GlobalISel/MachineIRBuilderTest.cpp
  llvm/unittests/CodeGen/GlobalISel/PatternMatchTest.cpp

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D99692.334559.patch
Type: text/x-patch
Size: 44373 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20210331/274810f4/attachment.bin>


More information about the llvm-commits mailing list