[PATCH] D98147: [SCEV] Improve modelling for pointer constants

Michael Kruse via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Fri Mar 12 08:49:15 PST 2021


Meinersbur accepted this revision.
Meinersbur added a comment.
This revision is now accepted and ready to land.

LGTM, thank you.



================
Comment at: polly/lib/Analysis/ScopBuilder.cpp:1764
 
+  if (auto *X = dyn_cast<SCEVUnknown>(DestAccFunc)) {
+    if (isa<ConstantPointerNull>(X->getValue()))
----------------
lebedev.ri wrote:
> Meinersbur wrote:
> > I used `X` to make a quick patch, maybe you can find a better name.
> Let's go with `U`nknown, not sure if better?
Find with me.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D98147/new/

https://reviews.llvm.org/D98147



More information about the llvm-commits mailing list