[PATCH] D98147: [SCEV] Improve modelling for pointer constants

Roman Lebedev via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Fri Mar 12 01:21:44 PST 2021


lebedev.ri added inline comments.


================
Comment at: polly/lib/Analysis/ScopBuilder.cpp:1764
 
+  if (auto *X = dyn_cast<SCEVUnknown>(DestAccFunc)) {
+    if (isa<ConstantPointerNull>(X->getValue()))
----------------
Meinersbur wrote:
> I used `X` to make a quick patch, maybe you can find a better name.
Let's go with `U`nknown, not sure if better?


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D98147/new/

https://reviews.llvm.org/D98147



More information about the llvm-commits mailing list