[PATCH] D98149: [lld-macho][nfc] Remove `MachO::` prefix where possible

Jez Ng via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Mar 8 11:45:45 PST 2021


int3 marked an inline comment as done.
int3 added inline comments.


================
Comment at: lld/MachO/InputFiles.cpp:115
   const char *buf = mbref.getBufferStart();
-  auto *hdr = reinterpret_cast<const MachO::fat_header *>(buf);
+  auto *hdr = reinterpret_cast<const fat_header *>(buf);
   if (mbref.getBufferSize() < sizeof(uint32_t) ||
----------------
oontvoo wrote:
> lint suggestion: `const auto * hdr`  ?
I think this lint rule needs to be smarter here, repeating `const` on the same line is silly. But updated to squelch the lint noise.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D98149/new/

https://reviews.llvm.org/D98149



More information about the llvm-commits mailing list