[PATCH] D98149: [lld-macho][nfc] Remove `MachO::` prefix where possible

Vy Nguyen via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Mar 8 09:32:25 PST 2021


oontvoo added a comment.

+1 for the removal of MachO::  prefix where possible.

W.R.T `Symbol` conflict, IMO, that's what namespaces are for. /shrug. (Agreed that it's probably not worth renaming the tapi Symbol, given the current tooling in llvm- that is to say, there's none :\ )



================
Comment at: lld/MachO/InputFiles.cpp:115
   const char *buf = mbref.getBufferStart();
-  auto *hdr = reinterpret_cast<const MachO::fat_header *>(buf);
+  auto *hdr = reinterpret_cast<const fat_header *>(buf);
   if (mbref.getBufferSize() < sizeof(uint32_t) ||
----------------
lint suggestion: `const auto * hdr`  ?


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D98149/new/

https://reviews.llvm.org/D98149



More information about the llvm-commits mailing list