[PATCH] D91727: [LAA] NFC: Rename [get]MaxSafeRegisterWidth -> [get]MaxSafeVectorWidthInBits
Cullen Rhodes via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Fri Nov 20 03:43:14 PST 2020
c-rhodes added inline comments.
================
Comment at: llvm/lib/Transforms/Vectorize/LoopVectorize.cpp:5341
- WidestRegister = std::min(WidestRegister, MaxSafeRegisterWidth);
+ WidestRegister = std::min(WidestRegister, MaxSafeVectorWidthInBits);
----------------
ctetreau wrote:
> Should WidestRegister get renamed also?
> Should WidestRegister get renamed also?
We'll probably look at changing this as well when we add support for scalable VFs here.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D91727/new/
https://reviews.llvm.org/D91727
More information about the llvm-commits
mailing list