[PATCH] D89395: [Flang][OpenMP 4.5] Add semantic check for OpenMP shared and private clause

Tim Keith via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Oct 14 10:28:14 PDT 2020


tskeith added inline comments.


================
Comment at: flang/lib/Semantics/check-directive-structure.h:212
+                if (const parser::StructureComponent *
+                    ssc{CheckAssociatedVariant(*name, *dataRef)}) {
+
----------------
This code just seems to be trying to determine if ompObject is a StructureComponent. If so, it could be simplified to:
```
if (parser::Unwrap<parser::StructureComponent>(ompObject)) {
```


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D89395/new/

https://reviews.llvm.org/D89395



More information about the llvm-commits mailing list