[PATCH] D85081: [lld-macho] Support dynamic linking of thread-locals

Shoaib Meenai via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Aug 12 18:18:46 PDT 2020


smeenai added a comment.

In D85081#2214557 <https://reviews.llvm.org/D85081#2214557>, @int3 wrote:

>> I don't see this one? LGTM otherwise.
>
> Whoops, I carefully checked off all the inline ones but forgot to look at the non-inline one 😅I've extended tlv-dylib to have a GOT entry.

Hah, I figured. Thanks!



================
Comment at: lld/MachO/Symbols.h:63
+  // referenced by both these sections at once.
   uint32_t gotIndex = UINT32_MAX;
 
----------------
int3 wrote:
> smeenai wrote:
> > smeenai wrote:
> > > It's slightly confusing to have `gotIndex` possibly refer to the TLV index, but I can't immediately think of a better name (short of `gotOrTlvIndex` or perhaps something like `pointerSectionIndex`).
> > Do you have any better naming ideas for this?
> hm, I think this is fine... I personally think of the TLV section as "GOT for thread locals", so this naming doesn't seem too far off the mark
Sure, works for me.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D85081/new/

https://reviews.llvm.org/D85081



More information about the llvm-commits mailing list