[PATCH] D85081: [lld-macho] Support dynamic linking of thread-locals

Jez Ng via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Aug 12 18:16:52 PDT 2020


int3 added a comment.

> I don't see this one? LGTM otherwise.

Whoops, I carefully checked off all the inline ones but forgot to look at the non-inline one 😅I've extended tlv-dylib to have a GOT entry.



================
Comment at: lld/MachO/InputSection.cpp:61
+std::string lld::toString(const InputSection *isec) {
+  return (toString(isec->file) + ":(" + isec->name + ")").str();
+}
----------------
NB: this is the same format used by LLD-ELF


================
Comment at: lld/MachO/Symbols.h:63
+  // referenced by both these sections at once.
   uint32_t gotIndex = UINT32_MAX;
 
----------------
smeenai wrote:
> smeenai wrote:
> > It's slightly confusing to have `gotIndex` possibly refer to the TLV index, but I can't immediately think of a better name (short of `gotOrTlvIndex` or perhaps something like `pointerSectionIndex`).
> Do you have any better naming ideas for this?
hm, I think this is fine... I personally think of the TLV section as "GOT for thread locals", so this naming doesn't seem too far off the mark


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D85081/new/

https://reviews.llvm.org/D85081



More information about the llvm-commits mailing list