[PATCH] D85080: [lld-macho] Support static linking of thread-locals
Saleem Abdulrasool via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed Aug 5 12:00:13 PDT 2020
compnerd accepted this revision.
compnerd added inline comments.
This revision is now accepted and ready to land.
================
Comment at: lld/MachO/InputSection.h:42
+
+inline bool isThreadLocalVariables(uint8_t flags) {
+ return (flags & llvm::MachO::SECTION_TYPE) ==
----------------
int3 wrote:
> compnerd wrote:
> > nit: I think `isThreadLocalVariable` is a better name (the flag is checked on a single symbol)
> it's being checked on a section (which can contain many TLVs), not a symbol
Ah, that's confusing. Perhaps it makes sense to make this a member of `OutputSection` (would be a good follow up change).
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D85080/new/
https://reviews.llvm.org/D85080
More information about the llvm-commits
mailing list