[PATCH] D81863: [gicombiner] Allow generated combiners to store additional members
Daniel Sanders via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Mon Jun 15 15:29:53 PDT 2020
dsanders marked an inline comment as done.
dsanders added inline comments.
================
Comment at: llvm/lib/Target/AArch64/GISel/AArch64PostLegalizerCombiner.cpp:298
public:
- AArch64GenPostLegalizerCombinerHelper Generated;
+ AArch64GenPostLegalizerCombinerHelperRuleConfig GeneratedRuleCfg;
----------------
aditya_nandakumar wrote:
> These names are getting a bit too long. Can we come up with a better naming scheme for these?
I agree but it's written exactly once so I'm not too worried about it at the moment. It could become a problem if we start passing them around though. I might make it a class-scoped class at some point but that won't really make it any shorter in this particular definition (actually it will add `::` to it).
Part of the current name is user selected so it's really `${prefix}RuleConfig`. Maybe tablegen should let you pick both names (that would prevent class-scoping it but that's not much of a loss).
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D81863/new/
https://reviews.llvm.org/D81863
More information about the llvm-commits
mailing list