[PATCH] D81850: [AArch64][SVE] NFC: Choose consistent naming for predicated SDAG nodes
Paul Walker via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Mon Jun 15 10:23:33 PDT 2020
paulwalker-arm added inline comments.
================
Comment at: llvm/lib/Target/AArch64/AArch64ISelLowering.h:32
+//
+// _PRED_M The result value is a vector with false lanes equal to
+// the first source operand.
----------------
Nothing really against the names, being short is certainly a benefit over my next suggestion.
Is is worth being explicit when it comes to merging. For example _MERGE_OP1 and _MERGE_ZERO. Here MERGE implies a predicated operation and it's clear from the name where the results for inactive lanes comes from. Here I'm referring to _PRED_PASSTHRU where such things are not clear. In essence I'm suggesting forcing people to clearly state where the passthrough value comes from in all cases.
================
Comment at: llvm/lib/Target/AArch64/AArch64ISelLowering.h:38
+//
+// _PRED_X The result value is a vector where values of false lanes
+// are explicitly left unspecified.
----------------
Given the above I'm wondering if this needs a special name, and if _PRED can be used for these cases as well as you describe below. I don't think there's any overlap so it's meaning should be clear.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D81850/new/
https://reviews.llvm.org/D81850
More information about the llvm-commits
mailing list