[PATCH] D76742: [lld] Add basic symbol table output
Jez Ng via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Mon Mar 30 18:03:10 PDT 2020
int3 added inline comments.
================
Comment at: lld/MachO/InputSection.h:49
uint32_t align = 1;
+ uint32_t nSect = 0;
uint32_t flags = 0;
----------------
I think we should name this `sectionIndex` in accordance with lld-ELF's OutputSection::sectionIndex. (I've made that change in D76839)
================
Comment at: lld/test/MachO/symtab_basic.s:1
+# REQUIRES: x86
+# RUN: llvm-mc -filetype=obj -triple=x86_64-apple-darwin %s -o %t.o
----------------
naming nits:
1) Use hyphens instead of underscores for test names (consistent with other lld tests)
2) The "_basic" suffix seems a bit unnecessary since this will (hopefully quickly) become a non-basic test
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D76742/new/
https://reviews.llvm.org/D76742
More information about the llvm-commits
mailing list