[PATCH] D75939: [x86][seses] Introduce SESES pass for LVI

Craig Topper via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Mar 11 09:37:18 PDT 2020


craig.topper added inline comments.


================
Comment at: llvm/lib/Target/X86/X86SpeculativeExecutionSideEffectSuppression.cpp:36
+static cl::opt<bool> OnlyFirstLFENCE(
+    "x86-seses-only-first-lfence",
+    cl::desc(
----------------
Something like x86-seses-one-lfence-per-bb might make a clearer name?


================
Comment at: llvm/lib/Target/X86/X86SpeculativeExecutionSideEffectSuppression.cpp:146
+// function since one of their operands will always be the EFLAGS register.
+static bool hasConstantAddressingMode(const MachineInstr &MI) {
+  for (const MachineOperand &MO : MI.uses()) {
----------------
Can this be ordered earlier to avoid the forward declaration?


================
Comment at: llvm/test/CodeGen/X86/O3-pipeline.ll:184
 ; CHECK-NEXT:       Live DEBUG_VALUE analysis
+; CHECK-NEXT:       X86 Speculative Execution Side Effect Suppression Pass
 ; CHECK-NEXT:       X86 Retpoline Thunks
----------------
Drop " Pass". Doesn't look like most other passes refer to themselves as Pass


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D75939/new/

https://reviews.llvm.org/D75939





More information about the llvm-commits mailing list