[PATCH] D74391: [llvm-readelf] Match GNU readelf more more closely when dumping notes
James Henderson via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue Feb 11 02:44:53 PST 2020
jhenderson added inline comments.
================
Comment at: llvm/tools/llvm-readobj/ELFDumper.cpp:4582-4585
std::string string;
raw_string_ostream OS(string);
- OS << format("Unknown note type (0x%08x)", NT);
+ OS << format("Unknown note type: (0x%08x)", NT);
return OS.str();
----------------
Would you mind refactoring this block into a separate function, to avoid all the code duplication? Perhaps called "getUnknownNoteTypeName" or something like that.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D74391/new/
https://reviews.llvm.org/D74391
More information about the llvm-commits
mailing list