[PATCH] D74221: [TargetLowering] Add NegatibleKind enum for isNegatibleForFree return codes
Dávid Bolvanský via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Fri Feb 7 07:15:57 PST 2020
xbolva00 added a comment.
+1, useful.
================
Comment at: llvm/include/llvm/CodeGen/TargetLowering.h:3507
+ /// more expensive, the same cost or cheaper.
+ virtual NegatibleKind isNegatibleForFree(SDValue Op, SelectionDAG &DAG,
+ bool LegalOperations,
----------------
name - isNegatibleForFree - hints that that this function probably returns bool.
Maybe we should rename it too - what do you think?
getNegatibleKind?
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D74221/new/
https://reviews.llvm.org/D74221
More information about the llvm-commits
mailing list