[PATCH] D74006: [MC][ELF] Make linked-to symbol name part of ELFSectionKey

Fangrui Song via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Feb 5 12:01:43 PST 2020


MaskRay marked 2 inline comments as done.
MaskRay added inline comments.


================
Comment at: llvm/include/llvm/MC/MCContext.h:199
+    // combined into one section.
     struct ELFSectionKey {
       std::string SectionName;
----------------
bd1976llvm wrote:
> MaskRay wrote:
> > bd1976llvm wrote:
> > > Here start using "linked_to" terminology instead of "associated". Should we stick to just one?
> > "linked-to section" is used by the ELF spec. By analogy, I use "linked-to symbol" here (omitted "Sym" in "LinkedToName"). "linked-to" implies a directed edge and makes it clear its relation with "sh_link", while one can argue that "associated" means an undirected edge. I think we should rename MCSymbol related "Associated" to "LinkedToSym". The IR level "!associated" can be left unchanged. I can do that in a separate change.
> SGTM.
Created D74082 to rename Associated to LinkedToSym


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D74006/new/

https://reviews.llvm.org/D74006





More information about the llvm-commits mailing list