[PATCH] D73620: Add 'gpu.terminator' operation.

Mehdi AMINI via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Jan 30 10:30:31 PST 2020


mehdi_amini added a comment.

In D73620#1848957 <https://reviews.llvm.org/D73620#1848957>, @ftynse wrote:

> In D73620#1847103 <https://reviews.llvm.org/D73620#1847103>, @mehdi_amini wrote:
>
> > D71961 <https://reviews.llvm.org/D71961> is going in the direction of generalizing std.return ; what is the guideline for adding a new op vs re-using std.return?
>
>
> This diff introduces a terminator that is explicitly "not a return", due to the confusion that appeared in a previous change wrt its semantics. In particular, it is used inside `gpu.launch` potentially inside `std.func`, it is never expected to have operands.  When the generalization of `std.return`, I would consider replacing `gpu.return` with `std.return` if compatible, but not `gpu.terminator`.


I don't think I agree with this. The discussion on generalizing std.return goes against this as far as I understand it.

Why was this committed while we're discussing here?


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D73620/new/

https://reviews.llvm.org/D73620





More information about the llvm-commits mailing list