[PATCH] D73592: [IRCE] Make IRCE a Function pass.
Johannes Doerfert via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue Jan 28 17:38:08 PST 2020
jdoerfert added a comment.
Two drive-by comments only.
================
Comment at: llvm/lib/Transforms/Scalar/InductiveRangeCheckElimination.cpp:1783
if (!IsSubloop)
- U.addSiblingLoops(NL);
+ appendLoopsToWorklist(*NL, Worklist);
};
----------------
I know this is not your code but I fail to see why the `LPMAddNewLoop` is different here from below. If it wasn't we could merge almost all of the `run` code into a common helper.
================
Comment at: llvm/lib/Transforms/Utils/LoopUtils.cpp:1481
+template void llvm::appendLoopsToWorklist<Loop &>(
+ Loop &Loops, SmallPriorityWorklist<Loop *, 4> &Worklist);
+
----------------
Nit: `Loops` is not the right name anymore.
We could probably also just call the array ref version with `{&L}`
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D73592/new/
https://reviews.llvm.org/D73592
More information about the llvm-commits
mailing list