[PATCH] D71346: [PowerPC] support loop ds form prep for lwa
Nemanja Ivanovic via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue Dec 17 10:56:48 PST 2019
nemanjai accepted this revision.
nemanjai added a comment.
This revision is now accepted and ready to land.
Other than the minor nit about readability, LGTM.
================
Comment at: llvm/lib/Target/PowerPC/PPCLoopInstrFormPrep.cpp:850
return !isa<IntrinsicInst>(I) &&
((PtrValue->getType()->getPointerElementType()->isIntegerTy(64)) ||
(PtrValue->getType()->getPointerElementType()->isFloatTy()) ||
----------------
This expression is quite unwieldy. The repeated calls to `PtrValue->getType()->getPointerElementType()` just look a bit messy. It would make sense to define a local variable to simplify this condition.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D71346/new/
https://reviews.llvm.org/D71346
More information about the llvm-commits
mailing list