[PATCH] D70758: [PowerPC][NFC] Rename record instructions to use _record suffix instead of o

Nemanja Ivanovic via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Dec 3 04:32:18 PST 2019


nemanjai added a comment.

I was originally going to suggest a more verbose suffix much as Hal suggested, since any single letter is kind of meaningless. But to be honest, I hate the added verbosity and feel that instruction mnemonics are just an inherently tricky thing that requires experience with the ISA document.

So since the status quo is at the top of my list of naming convention preferences in this case, I will abstain from further comments and will accept whatever the majority decides.



================
Comment at: llvm/lib/Target/PowerPC/PPCISelLowering.cpp:1370
   case PPCISD::UINT_VEC_TO_FP:  return "PPCISD::UINT_VEC_TO_FP";
-  case PPCISD::ANDIo_1_EQ_BIT:  return "PPCISD::ANDIo_1_EQ_BIT";
-  case PPCISD::ANDIo_1_GT_BIT:  return "PPCISD::ANDIo_1_GT_BIT";
+  case PPCISD::ANDI_record_1_EQ_BIT:  return "PPCISD::ANDI_record_1_EQ_BIT";
+  case PPCISD::ANDI_record_1_GT_BIT:  return "PPCISD::ANDI_record_1_GT_BIT";
----------------
Ugh.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D70758/new/

https://reviews.llvm.org/D70758





More information about the llvm-commits mailing list