[PATCH] D69709: [yaml2obj][WIP] - Add a way to describe the custom data that is not part of an output section.
Fangrui Song via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Mon Nov 4 21:50:31 PST 2019
MaskRay added inline comments.
================
Comment at: llvm/lib/ObjectYAML/ELFEmitter.cpp:94
+struct PhdrEntry {
+ uint64_t ShOffset;
+ uint64_t ShSize;
----------------
MaskRay wrote:
> `SegmentFragment` may be a better name. `Phdr` (program header) looks to me properties that describe the program header, but here this structure describes fragments that make up the segment content.
The name is inspired by `MCFragment`, a concept in MC. It has several subclasses such as MCFillFragment, MCPaddingFragment, etc.
We probably should drop the `Segment` prefix from the name `SegmentFragment`. This structure can describe fragments of non-segment part as well, e.g. gaps between 2 non-SHF_ALLOC sections.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D69709/new/
https://reviews.llvm.org/D69709
More information about the llvm-commits
mailing list