[PATCH] D68062: Propeller lld framework for basicblock sections
Fangrui Song via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Fri Sep 27 00:34:34 PDT 2019
MaskRay added inline comments.
================
Comment at: lld/ELF/Propeller.cpp:27
+#include "Config.h"
+#include "PropellerBBReordering.h"
+#include "PropellerELFCfg.h"
----------------
PropellerBBReordering.h is added in D68073, not in this patch. Please make each patch compilable.
================
Comment at: lld/ELF/Propeller.cpp:51
+
+using std::string;
+using std::tuple;
----------------
Delete using std::$container.
================
Comment at: lld/ELF/Propeller.h:1
+#ifndef LLD_ELF_PROPELLER_H
+#define LLD_ELF_PROPELLER_H
----------------
MaskRay wrote:
> Add license notice.
> Use variableName instead of VariableName to conform to the local naming convention.
> Use variableName instead of VariableName to conform to the local naming convention.
This is not done.
================
Comment at: lld/ELF/Propeller.h:242
+ CfgMapTy CfgMap;
+ unique_ptr<Propfile> Propf;
+ // Lock to access / modify global data structure.
----------------
std::unique_ptr
std::mutex
================
Comment at: lld/ELF/PropellerELFCfg.h:156
+ void emplaceEdge(ELFCfgEdge *Edge) {
+ if (Edge->Type < ELFCfgEdge::INTER_FUNC_CALL) {
+ IntraEdges.emplace_back(Edge);
----------------
Delete `{}`
This is applicable to many places of the patch series.
Repository:
rLLD LLVM Linker
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D68062/new/
https://reviews.llvm.org/D68062
More information about the llvm-commits
mailing list