[PATCH] D66132: [CodeGen] Add `shouldDoPartialRedundancyElimination()` to `TargetInstrInfo` (PRR42405)

Anton Afanasyev via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Aug 14 01:27:23 PDT 2019


anton-afanasyev added inline comments.


================
Comment at: llvm/include/llvm/CodeGen/TargetInstrInfo.h:1026-1028
+  /// This prevents MIR code from SimplePRE optimization leading to possible
+  /// speculative execution of instructions.
+  virtual bool isSpeculativeExecutionForbidden() const { return false; }
----------------
lebedev.ri wrote:
> Regardless of my bikeshedding if this is the correct fix or not,
> this should be renamed to be less misleading.
> Just name it `shouldDoPartialRedundancyElimination()` ?
Ok, done


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D66132/new/

https://reviews.llvm.org/D66132





More information about the llvm-commits mailing list