[PATCH] D65976: [Transforms] Add a emitBinaryFloatFnCall() version that fetches the function name from TLI
Evandro Menezes via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Fri Aug 9 09:40:56 PDT 2019
evandro marked 3 inline comments as done.
evandro added inline comments.
================
Comment at: llvm/lib/Transforms/Utils/BuildLibCalls.cpp:1093
+ // Get the name of the function according to TLI.
+ StringRef Name = getUnaryFloatFn(TLI, Op1->getType(),
+ DoubleFn, FloatFn, LongDoubleFn);
----------------
xbolva00 wrote:
> evandro wrote:
> > xbolva00 wrote:
> > > getUnaryFloatFn.. is this ok?
> > It's a poorly named function. It's agnostic about the number of arguments of the function.
> Thanks.
>
> Can you rename it as separate NFC patch?
👍
Repository:
rL LLVM
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D65976/new/
https://reviews.llvm.org/D65976
More information about the llvm-commits
mailing list