[PATCH] D65976: [Transforms] Add a emitBinaryFloatFnCall() version that fetches the function name from TLI
Dávid Bolvanský via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Thu Aug 8 15:38:03 PDT 2019
xbolva00 added inline comments.
================
Comment at: llvm/lib/Transforms/Utils/BuildLibCalls.cpp:1093
+ // Get the name of the function according to TLI.
+ StringRef Name = getUnaryFloatFn(TLI, Op1->getType(),
+ DoubleFn, FloatFn, LongDoubleFn);
----------------
evandro wrote:
> xbolva00 wrote:
> > getUnaryFloatFn.. is this ok?
> It's a poorly named function. It's agnostic about the number of arguments of the function.
Thanks.
Can you rename it as separate NFC patch?
Repository:
rL LLVM
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D65976/new/
https://reviews.llvm.org/D65976
More information about the llvm-commits
mailing list