[PATCH] D63879: [yaml2obj] - Allow overriding sh_offset field from the YAML.

Fangrui Song via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Fri Jun 28 04:09:50 PDT 2019


MaskRay added inline comments.


================
Comment at: lib/ObjectYAML/ELFYAML.cpp:916
+  assert(!IO.outputting());
+  IO.mapOptional("ShOffset", Section.ShOffset);
 }
----------------
grimar wrote:
> jhenderson wrote:
> > I'd call this "Offset" not "ShOffset", to better match the other fields.
> So seems we agreed "ShOffset" makes sence, I leaved it as is.
Since the fields are already spelled this way: `Flags`.. I'll not bother asking you to change that. `ShOffset` seems fine. It is better than `Offset` I think.

(I'd prefer unmangled elf.h names: `sh_flags`, `sh_offset`, etc)


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D63879/new/

https://reviews.llvm.org/D63879





More information about the llvm-commits mailing list