[PATCH] D63879: [yaml2obj] - Allow overriding sh_offset field from the YAML.
George Rimar via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Fri Jun 28 03:33:33 PDT 2019
grimar added inline comments.
================
Comment at: lib/ObjectYAML/ELFYAML.cpp:915
+
+ assert(!IO.outputting());
+ IO.mapOptional("ShOffset", Section.ShOffset);
----------------
jhenderson wrote:
> This assert seems a bit out-of-place?
Yes, it was a bit incomplete. Fixed.
================
Comment at: lib/ObjectYAML/ELFYAML.cpp:916
+ assert(!IO.outputting());
+ IO.mapOptional("ShOffset", Section.ShOffset);
}
----------------
jhenderson wrote:
> I'd call this "Offset" not "ShOffset", to better match the other fields.
So seems we agreed "ShOffset" makes sence, I leaved it as is.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D63879/new/
https://reviews.llvm.org/D63879
More information about the llvm-commits
mailing list