[PATCH] D60137: Describe stack-id as an enum

Sander de Smalen via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Apr 3 04:55:56 PDT 2019


sdesmalen marked an inline comment as done.
sdesmalen added inline comments.


================
Comment at: include/llvm/CodeGen/MIRYamlMapping.h:316
+    IO.enumCase(ID, "default", TargetStackID::Default);
+    IO.enumCase(ID, "sgpr_spill", TargetStackID::SGPR_Spill);
+    IO.enumCase(ID, "noalloc", TargetStackID::NoAlloc);
----------------
arsenm wrote:
> I think using - instead of _ follows the current naming conventions.
> 
> I'm not sure a target specific usage should be put here, but maybe
Good point, I'll make sure the next iteration of the patch uses '-' instead!


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D60137/new/

https://reviews.llvm.org/D60137





More information about the llvm-commits mailing list