[PATCH] D60137: Describe stack-id as an enum
Matt Arsenault via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue Apr 2 09:34:33 PDT 2019
arsenm added inline comments.
================
Comment at: include/llvm/CodeGen/MIRYamlMapping.h:316
+ IO.enumCase(ID, "default", TargetStackID::Default);
+ IO.enumCase(ID, "sgpr_spill", TargetStackID::SGPR_Spill);
+ IO.enumCase(ID, "noalloc", TargetStackID::NoAlloc);
----------------
I think using - instead of _ follows the current naming conventions.
I'm not sure a target specific usage should be put here, but maybe
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D60137/new/
https://reviews.llvm.org/D60137
More information about the llvm-commits
mailing list