[PATCH] D56587: Introduce DW_OP_LLVM_convert
Markus Lavin via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Fri Mar 1 00:49:22 PST 2019
markus marked 2 inline comments as done.
markus added a comment.
> We're almost there!
Yay :)
================
Comment at: lib/CodeGen/AsmPrinter/DwarfDebug.cpp:1947
+ uint32_t Offset = 0;
+ for (auto &Op : Expr) {
+ Streamer.EmitInt8(Op.getCode(), Comment != End ? *(Comment++) : "");
----------------
aprantl wrote:
> Could you please still factor this into a static fixupBaseTypeRefs(or something along those lines) function for better readability?
Sure, but I don't understand where to place the cut to improve readability. I.e. what should go into `fixupBaseTypeRefs` and what should remain in `emitDebugLocEntry`?
================
Comment at: lib/CodeGen/AsmPrinter/DwarfDebug.cpp:1952
+ if (Op.getDescription().Op[I] == Encoding::SizeNA)
+ continue;
+ if (Op.getDescription().Op[I] == Encoding::BaseTypeRef) {
----------------
aprantl wrote:
> Where is this getting copied?
It is not getting copied at all, 'Encoding::SizeNA` indicates that the operation does not have an operand in this slot. Or maybe I am not understanding the question?
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D56587/new/
https://reviews.llvm.org/D56587
More information about the llvm-commits
mailing list