[PATCH] D57700: [llvm-readobj] Display sections that do not belong to a segment in the section-mapping

James Henderson via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Feb 5 01:50:56 PST 2019


jhenderson added a comment.

I'm happy with this, but since I was the one who suggested this offline, and I'm aware that there might be some reluctance to accept it from elsewhere, I'd like some other people's comments on it.



================
Comment at: llvm/tools/llvm-readobj/ELFDumper.cpp:3345
+  // Display sections that do not belong to a segment.
+  std::string None;
+  for (const Elf_Shdr &Sec : unwrapOrError(Obj->sections())) {
----------------
I'd rename this variable to something else, either Sections, like above or NoSegmentSections or similar. The reason is to a void any potential confusion with Optional::None. The latter name is also slightly more self-documenting.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D57700/new/

https://reviews.llvm.org/D57700





More information about the llvm-commits mailing list