[PATCH] D57608: [NFC][GlobalISel]: Add a convenience method to MachineInstrBuilder to simplify getOperand(i).getReg()
Matt Arsenault via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Sat Feb 2 07:52:00 PST 2019
arsenm added a comment.
In D57608#1382034 <https://reviews.llvm.org/D57608#1382034>, @kparzysz wrote:
> In D57608#1381719 <https://reviews.llvm.org/D57608#1381719>, @aemerson wrote:
>
> > If we're going to add a helper to shave some characters off, we might as well go for something really short like getOpReg().
>
>
> Or simply `getReg(unsigned OpIdx)`---this would keep the names identical. Also, should there be something like this for subregs as well?
No, subregisters should never exist for G_* instructions
Repository:
rL LLVM
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D57608/new/
https://reviews.llvm.org/D57608
More information about the llvm-commits
mailing list