[PATCH] D57602: [WebAssembly] Add an import_field function attribute
Dan Gohman via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Fri Feb 1 12:02:14 PST 2019
sunfish added a comment.
In D57602#1381220 <https://reviews.llvm.org/D57602#1381220>, @sbc100 wrote:
> Do you could also achieve this I guess by renaming pwsix.read function itself to pwsix.__read? But I guess it makes sense to allow the use to control all 3 parts of the name separately.
Yeah. As another example, if I wanted to import "print_i32" from "spectest", I might want C to call it "spectest_print_i32" or something, and not be forced to have it occupy "print_i32" in C's global namespace.
> BTW, I've never liked the word field here. I think "wasm-import-name" would make more sense, but that would conflict with the spec I suppose, and also this should be very rarely needed attr.
I just checked the spec and it does't actually use the word "field" here. So I'll rename this attribute to "import_name" and "wasm-import-name".
Repository:
rL LLVM
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D57602/new/
https://reviews.llvm.org/D57602
More information about the llvm-commits
mailing list