[PATCH] D56401: [WebAssembly] Fix updating/moving DBG_VALUEs in RegStackify
Heejin Ahn via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Thu Jan 10 17:20:16 PST 2019
aheejin added inline comments.
================
Comment at: lib/Target/WebAssembly/WebAssemblyRegStackify.cpp:43
+class AdjacentDebugValues {
+ MachineInstr *Def;
----------------
aheejin wrote:
> yurydelendik wrote:
> > aheejin wrote:
> > > It's still not in the anonymous namespace I think..?
> > > Also, not sure about the name `AdjacentDebugValues`.. which sounds like there are also non-adjacent DBG_VALUE instructions.
> > As I understand DBG_VALUE concept, there can be DBG_VALUE without defining MI. Changed name to `MachineInstrAdjacentDebugValues`
> Hmm, sorry, how about `DebugValueHandler` or something?
Or, `DebugValueManager`?
Repository:
rL LLVM
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D56401/new/
https://reviews.llvm.org/D56401
More information about the llvm-commits
mailing list