[PATCH] D56401: [WebAssembly] Fix updating/moving DBG_VALUEs in RegStackify
Heejin Ahn via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Thu Jan 10 17:13:46 PST 2019
aheejin added a comment.
One thing I'm curious about is, is this kind of logic that gathers/moves DBG_VALUEs only needed in RegStackify? Don't you need that also in other passes? What about your new ExplicitLocal patch? If you need that in several place, how about moving this class to WebAssemblyUtilities or something and use it from many places?
================
Comment at: lib/Target/WebAssembly/WebAssemblyRegStackify.cpp:43
+class AdjacentDebugValues {
+ MachineInstr *Def;
----------------
yurydelendik wrote:
> aheejin wrote:
> > It's still not in the anonymous namespace I think..?
> > Also, not sure about the name `AdjacentDebugValues`.. which sounds like there are also non-adjacent DBG_VALUE instructions.
> As I understand DBG_VALUE concept, there can be DBG_VALUE without defining MI. Changed name to `MachineInstrAdjacentDebugValues`
Hmm, sorry, how about `DebugValueHandler` or something?
Repository:
rL LLVM
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D56401/new/
https://reviews.llvm.org/D56401
More information about the llvm-commits
mailing list