[PATCH] D55919: [DebugInfo] Omit location list entries with empty ranges
Adrian Prantl via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Mon Jan 7 09:52:45 PST 2019
aprantl added inline comments.
================
Comment at: lib/CodeGen/AsmPrinter/DwarfDebug.cpp:1188
+ // variable.
+ if (DIExpr->isFragment())
+ OpenRanges.push_back(Value);
----------------
dstenb wrote:
> aprantl wrote:
> > why not just move the condition two lines further down?
> Sorry for the late response due to the holiday season!
>
> I'm not sure I follow. Do you mean to merge this code with the `DIExpr->isFragment()` code at line 1198 somehow?
Yeah, this code block looks like it is repeated further down below and I was wondering if it could be simplified / deduplicated.
Repository:
rL LLVM
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D55919/new/
https://reviews.llvm.org/D55919
More information about the llvm-commits
mailing list