[PATCH] D54690: [WebAssembly] Rename function types to signatures
Sam Clegg via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Mon Nov 19 12:41:51 PST 2018
sbc100 added inline comments.
================
Comment at: test/wasm/Inputs/globals.yaml:11
- Type: FUNCTION
- FunctionTypes: [ 0 ]
+ FunctionSigIndices: [ 0 ]
- Type: GLOBAL
----------------
Again, not sure about this name change here.
================
Comment at: wasm/InputFiles.cpp:67
uint32_t ObjFile::calcNewIndex(const WasmRelocation &Reloc) const {
if (Reloc.Type == R_WEBASSEMBLY_TYPE_INDEX_LEB) {
+ assert(SigIsUsed[Reloc.Index]);
----------------
I guess we should really rename the relocation type too R_WEBASSEMBLY_SIG_INDEX_LEB or R_WEBASSEMBLY_SIGNATURE_INDEX_LEB.
Repository:
rLLD LLVM Linker
https://reviews.llvm.org/D54690
More information about the llvm-commits
mailing list