[PATCH] D53291: add riscv32e to the llvm
Simon Cook via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Mon Oct 15 08:44:59 PDT 2018
simoncook added inline comments.
================
Comment at: lib/Support/Triple.cpp:46
+ case riscv32e:
+ return "riscv32e";
case riscv64: return "riscv64";
----------------
This should be on the same line as the case statement, similar to the rest of the table.
================
Comment at: lib/Target/RISCV/RISCVFrameLowering.cpp:27
+ : TargetFrameLowering(StackGrowsDown,
+ STI.isEmbed() ? 4 : /*StackAlignment=*/16,
+ /*LocalAreaOffset=*/0),
----------------
I think this would be more readable as `/*StackAlignment=*/ STI.isEmbed() ? 4 : 16,`
================
Comment at: lib/Target/RISCV/RISCVFrameLowering.h:24
public:
- explicit RISCVFrameLowering(const RISCVSubtarget &STI)
- : TargetFrameLowering(StackGrowsDown,
- /*StackAlignment=*/16,
- /*LocalAreaOffset=*/0),
- STI(STI) {}
+ explicit RISCVFrameLowering(const RISCVSubtarget &STIT);
----------------
Did you mean to put a 'T' on the end of this variable name?
Repository:
rL LLVM
https://reviews.llvm.org/D53291
More information about the llvm-commits
mailing list