[PATCH] D52764: [Intrinsic] Add llvm.minimum and llvm.maximum instrinsic functions
Thomas Lively via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed Oct 3 10:20:31 PDT 2018
tlively added inline comments.
================
Comment at: lib/CodeGen/SelectionDAG/SelectionDAGBuilder.cpp:5588
+ case Intrinsic::minimum:
+ setValue(&I, DAG.getNode(ISD::FMINNAN, sdl,
+ getValue(I.getArgOperand(0)).getValueType(),
----------------
arsenm wrote:
> Either as a dependency or an after-step, I think the DAG nodes should be renamed to match the intrinsic
I'd be happy to do this in a follow-on. This makes sense to me because the names `minnan` and `maxnan` imply that the only difference from `minnum` and `maxnum` is NaN propagation, which is not correct.
Repository:
rL LLVM
https://reviews.llvm.org/D52764
More information about the llvm-commits
mailing list