[PATCH] D51969: [AMDGPU] Add an AMDGPU specific atomic optimizer.

Matt Arsenault via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Sep 17 06:58:16 PDT 2018


arsenm added inline comments.


================
Comment at: lib/Target/AMDGPU/AMDGPUAtomicOptimizer.cpp:57
+
+  StringRef getPassName() const override { return "AMDGPU Atomic Optimizer"; }
+
----------------
sheredom wrote:
> arsenm wrote:
> > This can be dropped
> You mean I don't need to include a getPassName at all? I was just including it for consistency with the other AMDGPU level passes (a bunch at least have the method overridden).
Yes. We should be deleting them. I'm not sure why they exist in the first place - they are redundant with the name passed in the macro


https://reviews.llvm.org/D51969





More information about the llvm-commits mailing list