[PATCH] D47244: [llvm-mca] Rename the RetireControlUnit into RetireStage. NFC.
Andrea Di Biagio via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed May 23 02:51:24 PDT 2018
andreadb added a comment.
On a second thought,
wouldn't it be better if we still keep the RetireControlUnit abstraction?
We can have that the RetireStage acts as a proxy for the RetireControlUnit.
Basically, the logic in RetireStage::cycleEvent() and `onInstructionExecuted()` should be implemented by the "stage".
While, the actual RetireControlUnit functionality should live in its own class. I think it logically helps to distinguish between the actual pipeline process from the implementation of the RCU. It also allows the Stage to not be bound to a specific implementation of the RCU.
https://reviews.llvm.org/D47244
More information about the llvm-commits
mailing list