[PATCH] D47162: [WebAssembly] Initial support for LTO
Sam Clegg via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Mon May 21 17:14:07 PDT 2018
sbc100 added inline comments.
================
Comment at: wasm/InputFiles.cpp:374
+ BitcodeFile &F) {
+ StringRef NameRef = Saver.save(ObjSym.getName());
+
----------------
ruiu wrote:
> What does `Ref` means? I'd name this just `Name`.
Looks like I cargo-culted that from ELF/InputFiles.cpp. Fixed there too.
================
Comment at: wasm/LTO.cpp:57
+
+static void diagnosticHandler(const DiagnosticInfo &DI) {
+ SmallString<128> S;
----------------
ruiu wrote:
> Move this to Common/ErrorHandler.cpp.
Is it OK for ErrorHandler.h to include llvm/IR/DiagnosticInfo.h ? I was thinking of doing some followup changes to factor out some of the common LTO code.
Repository:
rLLD LLVM Linker
https://reviews.llvm.org/D47162
More information about the llvm-commits
mailing list