[PATCH] D44980: [MC][Tblgen] Allow the definition of processor register files in the scheduling model for llvm-mca
Andrea Di Biagio via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue Apr 3 04:55:56 PDT 2018
andreadb added inline comments.
================
Comment at: tools/llvm-mca/Dispatch.cpp:33
+ // means: this register file has an unbounded number of physical registers.
+ addRegisterFile({}, NumRegs);
+ if (!SM.hasExtraProcessorInfo())
----------------
andreadb wrote:
> courbet wrote:
> > ```addRegisterFile({} /*all registers*/, NumRegs);```
> >
> > (for readability) ?
> Yes. If you think it is not needed then I remove it.
Nevermind... I though I added it. Duh.
I am going to add that comment for readability. Cheers!
https://reviews.llvm.org/D44980
More information about the llvm-commits
mailing list