[PATCH] D43403: Refactor wasm/WriterUtil.{cpp,h}.

Sam Clegg via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Fri Feb 16 12:35:01 PST 2018


sbc100 accepted this revision.
sbc100 added a comment.
This revision is now accepted and ready to land.

Thanks!



================
Comment at: lld/wasm/WriterUtils.cpp:83
-void wasm::writeValueType(raw_ostream &OS, int32_t Type, const char *Msg) {
-  debugWrite(OS.tell(), Msg + formatv("[type: {0}]", valueTypeToString(Type)));
-  writeSleb128(OS, Type, nullptr);
----------------
I sometimes find the format string more readable than lots of small strings fragments +'d together.   But I don't feel strongly enough about to to break local convention.


https://reviews.llvm.org/D43403





More information about the llvm-commits mailing list